Welcome

Welcome to our Tips, Tricks and Traps database for EDA tools.  The purpose of this database is to provide the information most valuable to design engineers in a format which is quickly and easily accessible.  It is not a User Guide with a complete introduction to a program.  It is not a Reference Guide, with a detailed explanation of every feature.  It is not a Solutions Database, with solutions to thousands of obscure problems that have accumulated over the years.  It is not a newsgroup, with a flood of discussion on topics you don’t care about.  It is most closely related to an FAQ, but more extensive (eventually), better organized, and written by users.
What we seek to provide is help with the most common problems users have with a tool.  We assume you are already familiar with the basic menu structure of the tool.  With that knowledge, you can follow our outline and quickly locate an item relating to your problem, or you can read all items under a heading to become expert in that area.  You may, for example, want to be familiar with all of the traps in a tool, but only those tips and tricks relating to the features you use most often.
Items contributed by users are reviewed for accuracy and clarity by the Wizard for that particular tool.  All contributions are welcome, even if it’s just an alert to tell us something is out of date.  If you don’t find what you are looking for, go to your normal documentation and support channels.  When you find a solution to a problem of general interest, please write it up, and post it to the forum at http://forums.delphiforums.com/EDAtools .   This will provide an opportunity for discussion prior to inclusion in the TTT database.
Currently, we are using Microsoft Word, because we really like the expandable outline feature.  Later we will make this functionality directly available on the website.  We also plan to add filtering and sorting features so you can highlight your favorite contributors, or filter out those you don’t want cluttering your screen, or review what’s new since your last visit.
This database is organized by Tool, Menu, and Command, making it easy for users to locate all entries relevant to a particular command.  The source of a problem may be elsewhere, but the problem is entered at the point in the hierarchy where the designer may encounter it.  If a problem may appear in more than one place, it will be entered once, with links from the other places.
Click on each level of the hierarchy to expand or collapse it.  Numbers beside each collapsed level indicate how many entries (and links) there are in that branch.

General Tips, Tricks, & Traps

These are items which may not be associated with any one menu command.
Dangerous Traps (Nightmare scenarios)
Trap: Strange connections to vdd! and gnd!
This ranks as our most dangerous trap, because it can get past LVS and result in subtle problems that are almost impossible to isolate in production.

Trap:  Labels may revert to a previous state
This trap can cause an entire chip layout to be trashed, but at least it won’t get past LVS.  The parameters in the schematic database are correct.  Only the labels are off.  Run LVS frequently as the layout progresses.
Editing Symbols (1)

Trap: Must manually update CDF

After editing a symbol in a way that should change the CDF parameters (e.g. adding, deleting, or renaming a pin) it is necessary to manually update the CDF.

Solution:  This is done by opening the symbol for edit in Composer, then executing the following command in the CIW:

artGenerateHierSymbolCDF(geGetEditCellView())

Contibuted by:  Dave
Date:  3/28/02  Release:  4.4.7

Status:  PCR  412107 opened 11/15/01
Inherited Connections (1)

Trap: Strange connections to vdd! and gnd!

Many devices in analogLib use inherited connections to specify the body terminal.  These devices have a parameter called “Bulk node connection” on the Edit Object Properties form.  By default, this parameter is set to the source terminal ‘S’, even though the real connection is to net vdd!  Changing that parameter has no effect.  The problem is that this parameter applies only to “socket simulators” like SpectreS.  If you are not using a socket simulator, these parameters are ignored, and the bodies remain connected to their default nodes ( vdd! for a pmos, and gnd! for an nmos ).  This can cause subtle problems, like when the bodies of your analog transistors end up being connected to vdd! in some digital circuit the other side of the chip!!  These problems can occur long after your design is finished, when someone adds a vdd! in some unrelated part of the circuit.  Even worse, the problem may get past LVS into production circuits, where it may be impossible to track down.
Devices with inherited connections include the following:

pmos, pbsim, pjfet, pnp

nmos, nbsim, njfet, npn

Solution:  Be very careful with inherited connections in analog circuits.  Use four-terminal devices, which show the body connection explicitly.  Use

setenv  $CDS_No_Defaults_For_Inhconn  1, which will warn if there are any inherited connections that have not been explicitly set.  Use the Tool Filter ( Composer: Options -> Tool Filter… ) to filter out parameters that don’t work with the current simulator.

Contibuted by:  Dave
Date:  5/11/02  Release:  4.4.7

Status:  PCR  444331  No fix planned.

Mixed-signal simulations (1)

Trick: verilog.log window is hidden
Library Manager Tips, Tricks & Traps

File

Edit (1)

Delete (1)

Trap: Can lose an entire library!!

"Delete" means remove the entire library from disk (no recovery).  If you just want to delete the library from the current list in the Library Manager, use the Library Path Editor  (  Edit - Library Path - Edit - Remove Library Definition )

Contibuted by:  Dave
Date:  6/11/01  Release:  4.4.5

Status: 
View

Design Manager

Analog Artist Tips, Tricks, & Traps

Session ()

Setup (4)

Model Libraries  (3)

Trick: Setting Default Model Files

To set a default model file in the Model Library Setup form, add to your 

‘.cdsenv’ file a line like the following:

spectre.envOpts  modelFiles   string   “/cad/models/cs73/all.scs;nom”

or lines like the following:

spectre.envOpts  includePath  string  “/cad/models/cs73/”

spectre.envOpts  modelFiles   string  “xyzmodels.scs;nom”

Note: This example is for Spectre Direct.  Other simulators may vary.

Contibuted by:  Dave
Date:  8/17/01  Release:  4.4.6

Trap: Model Setup Form ignores ./
./ in the Model Library Setup form does not search the Artist current working directory.   It looks first in the Spectre ‘netlist’ directory, then in the paths specified under Setup - Simulation Files - Include Path.  The effect is the same as not having ./ at all, and can lead to use of the wrong models if there is a file with the same name in your Include Path.

Solution:  Put ./ as the first path  in the Setup – Simulation Files – Include Path.  Do not put ./ in the Model Library Setup form, as this may cause confusion.

Contibuted by:  Dave
Date:  7/4/01  Release:  4.4.6

Status:  PCR  368256 opened 4/4/01  Allow ./ in Model Setup.

Trap: Model file changes are not recognized
When you edit a model file during a session, Artist may not be aware that the file was changed, and subsequent simulations may continue to use parameters read in from the old file.

Solution:  Always remember to re-netlist after changing a model file.

Contibuted by:  Dave
Date:  7/4/01  Release:  4.4.6

Status:  PCR  368310 opened 4/4/01 asks for a 'makefile' to be generated with each netlist.  If any file upon which that netlist depends is ever changed, Artist will automatically generate a new netlist before starting a simulation.

Simulation Files(1)

Trick: Adding unsupported simulator commands

The Artist environment does not support all possible simulator commands.  For example, to save operating point results in a sweep or transient analysis, you need save options that aren’t available under Outputs -> Save All.  

Solution:  Add an ‘include file’ with the desired commands using Setup -> Simulation Files...   Either the ‘Definition File’ or the ‘Stimulus File’ field will work.  Be sure to include the path under ‘Include Path’ on the same form.

Contibuted by:  Dave
Date:  3/17/03  Release:  5.0

Status:  Many PCRs starting in April 1993, have asked that Artist support Spectre’s ability to produce operating point results.  “An idea whose time has come.”
Analyses ()

Variables ()

Outputs (1)

Select on Schematic  (1)

Trick: To select terminals with short wires

Cannot select terminals when they are connected to a very short wire.  The wire gets selected instead.

Solution:  Drag the little wire out of the way.  Select the terminal.  Then drag the little wire back.  Doesn’t work with read-only schematics.  In that case, use Composer:  Edit -> Select -> Filter…  and deselect wires.

Contibuted by:  Dave
Date:  8/3/01  Release:  4.4.6

Status:  PCR  192515 may be fixed in 4.4.8.

Simulation (1)

Run (1)

Trap: Netlist may be out-of-date!
The netlist sent to the simulator may not update when changes have been made to schematics, model files, or any simulation files (e.g. stimulus files).  The user may not realize the simulator is using the old netlist.

Solution:  Always use ‘Netlist and Run’ after any schematic changes.  Use Simulation -> Netlist -> Recreate after any file changes.

Contibuted by:  Dave
Date:  8/3/01  Release:  4.4.6

Status:  PCR 368310 opened 4/4/01 – Need Makefile for Netlists.

Results (1)

Trap: cp -r can fill your disk w garbage!

There is a recursive link in the results directory created by the Parametric Analysis tool  ( psf -> ./).  This can cause a nasty surprise.  When you try to copy results to another directory using the Unix command cp -r, it will get caught in an infinite loop.  

Solution:  The 'cp' command was not intended to copy links.  If you are making a backup, use 'tar' instead.  If you are simply copying results, use the Results - Save… command in Artist.  You can even add a comment.  In general, you should not use Unix commands for file management when a special command is available within your tool.
Contibuted by:  Dave
Date:  7/2/01  Release:  4.4.6

Status:  PCR  357662 closed 2/13/01.  No fix planned.

Tools (5)

Monte Carlo (3)

Main Form ()

Session ()

Outputs ()

Simulation (3)

Check Expressions

Define Correlations … ()

Create Input Files ()

Run (3)

Trap: Autoplot fails, even if sim completes normally

Don't you just love these error messages:

   Monte Carlo Simulation completed successfully...

   *Error* request.il asiiFinish: error in finish function ("ilGetInt"

    0 t nil ("*Error* ilGetInt: arg must be fixnum" nil))

Simulation appears to be hung!!!

Solution:  Problem was in the specification of Swept Parameter on the main form.  Items in the list of values should be separated by spaces not commas.  Click 'Simulation - Stop' to recover.

Contibuted by:  Dave
Date:  4/26/01  Release:  4.4.6

Status:  Fixed in release 4.4.7. (PCR 348573)

Trick: Filtering out non-convergent runs
Tip:  Use 'Check Expressions' to find outputs you forgot to save
Output Log  … ()

Results ()
Corners(1)

Trick: Accessing individual results with the Results Browser
The Corners tool creates a ‘Corners’ directory parallel to the ‘psf’ results directory, where the actual data from various corner runs is written.  Accessing  what appears to be indivdual results under the psf directory with the Results Browser generates plots of the entire family.   Accessing similar items under the ‘Corners’ directory generates screens full of garbage.

Solution:.  Under the ‘Corners’ directory, with the middle mouse button, select the name of the corner you wish to access.   Click ‘Create ROF’.  Then using the left mouse button select the result you want to access.  This puts an access function in the Calculator, from which you can plot or do further calculations.

To select additional individual results, repeat the ‘Create ROF’ operation.  Nothing changes in the Calculator, but the same access function now points to the most recently selected corner.

Contibuted by:  Dave
Date:  3/15/03  Release:  5.0

Results Browser(1)

Trick: Accessing individual results from the Corners tool

See Tools -> Corners
Composer Tips, Tricks, & Traps

Tools

Design (1)

Hierarchy (1)

Descend Edit …(1)

Trap: Must manually update CDF

See General TTT, Editing Symbols
Window

Edit (3)

Search - Replace (1)

Annoyance:  Last item doesn't redraw

When replacing several occurrences of a value such as one of the parameters on a component, the last item doesn't redraw with the new value.  You need to redraw the schematic (Window - Redraw) to be sure the last change was made.

Properties - Objects (1)

Trap:  Be Careful with Units

Be careful when entering units (u, K, etc.) for parameters in the Edit Object Properties  form.  If you type "2" when you meant "2u" your circuit may fail in a way that is very hard to debug.  This kind of error often occurs when you are typing over some text that is already in the parameter field.

Component Display (1)

Trap:  Labels may revert to a previous state

This is the second most dangerous bug in Artist.  Labels you thought were just right revert to a previous state after you close the schematic and send it to layout !!  It doesn't happen all the time, but often enough to have disastrous consequences.

Workaround:  Stay away from the (default)  'Apply to Library' or the 'Cell' option.  If you always limit the scope of your Parameter Label edits to 'instance' the labels seem to stick much better.  Also, in layout, you should do an LVS check early in the process.  The actual cell parameters are correct.  It's just the labels don't show the correct info (like a missing  m=8 on a transistor).  So the errors will be caught in LVS.

Contibuted by:  Dave
Date:  7/10/01  Release:  4.4.6

Status:  Bug has been isolated.  PCR  381455 opened  6/11/01.
Add (1)

Label (1)  [Symbol Editing]

Trap: @partName not updated after copy cell

After copying a cell and giving it a new name, the @partName label does not update to the new name.  If the user does not notice this, and manually change the name, it could cause serious problems later when the old cell is used in layout.

Workaround:  Instead of the Add - Label function, use Edit - Properties - Cellview, and turn ON the display of the Cell property.  For existing cells having  @partName, you must edit the symbols and change @partName to @cellName.

Contibuted by:  Dave
Date:  7/10/01  Release:  4.4.6

Status:  PCR  386679 opened  7/9/01
Check

Sheet

Options

Template

Trap: cp -r can fill your disk w garbage!

There is a recursive link in the results directory created by the Parametric Analysis tool  ( psf -> ./).  This can cause a nasty surprise.  When you try to copy results to another directory using the Unix command cp -r, it will get caught in an infinite loop.  

Solution:  The 'cp' command was not intended to copy links.  If you are making a backup, use 'tar' instead.  If you are simply copying results, use the Results - Save… command in Artist.  You can even add a comment.  In general, you should not use Unix commands for file management when a special command is available within your tool.

Contibuted by:  Dave
Date:  7/2/01  Release:  4.4.6

Status:  PCR  357662 closed 2/13/01.  No fix planned.
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